Risugami ModLoader for Minecraft 1.7.9/1.7.2

Modloader 1.6.2Risugami ModLoader is a modification manager for Minecraft which lets you easily install mods by other developers. Another version is up to release. Most importantly for the fans who were waiting for it.. ModLoader prevents the conflicts that other addons create such as. Rendering, GUI,  recipes and smeltables. This allows you to have multiple mods installed without need of worrying about compatibility and mismatch.

Description: Mod Loader is a mod manager (base mod) for Minecraft.
Filesize: 250~ KB
Author: Risugami
Release date: 8th July, 2013
Compatibility: Minecraft 1.6.4/1.7/1.7.1

Download ModLoader 1.7.2/1.7.3/1.7.4:

For 1.6.2 and above: ModLoader.zip (latest)

Previous versions (1.6.1, 1.4.7 etc): ModLoader.zip (archive)

How to install ModLoader in Minecraft:

 

Posted in Mods & Addons
57 comments Submit a comment
  • jjrice commented on November 21, 2012 at 10:08 pm

    it doesn’t work for me i use winRAR, but when i launched it, it wouldn’t work.

  • noahbub1 commented on December 10, 2012 at 2:59 am

    IT DIDNT WORK

  • iusty commented on December 20, 2012 at 1:47 pm

    yep…black screen…and i have deleted meta_inf…any suggestions for my problem?

  • Edvin commented on December 20, 2012 at 2:51 pm

    I only get a black screen..

  • yochai vaadia commented on December 20, 2012 at 4:28 pm

    i think the problem is in the modloader itself

  • Yeah, just a black screen, but im sure i deleted META-INF :/

  • Tristan commented on December 21, 2012 at 12:06 am

    i was using magic launcher and it works better then anything ive ever seen! i really recomend it! but as well as everyone else my modloader 1.4.6 didnt o-operate with me…it still isnt compatible…please fix

  • Southbird83 commented on December 21, 2012 at 12:17 am

    This was released for 1.4.6 beta back in November 20. It’s not ready for the 1.4.6 release today.

  • kitty commented on December 22, 2012 at 6:06 pm

    try it ! >:(

  • ChickenJewel commented on January 9, 2013 at 5:11 pm

    I tried a few times and all I get is the black screen can someone help?

  • i want this one

  • Heist5 commented on January 11, 2013 at 5:46 am

    No body download it. I just checked my computer, I have a virus, I scanned the program and the program contains the virus. This isn’t even the right coding for the file anyway. All of the .class files have the wrong coding. If you have it downloaded it delete it. I don’t know if the poster knew this was a virus or not but if you didn’t I suggest you take it down as your computer probably has the virus as well.
    No hate mail accepted, just trying to help out

  • fp999 commented on January 26, 2013 at 5:11 am

    does it work with 1.4.7

  • MCN00bPl0x commented on January 28, 2013 at 2:03 am

    I have downloaded it and no work WITH T.M.I. It says it is compatible but I had an error WITH Modloader +T.M.I. WTF!?!?

  • Maverick Rose commented on March 14, 2013 at 4:22 pm

    Dosnet work yet i got an big minecraft error dosent do other stuff like older loaders dont know maybe too new for 1.5 ?

  • SO AWESOME THAT MODLOADER UPDATES SO FAST!!!
    i just finished my mod called riggy mod. Thanks SO MUCH!

  • vwchevyrock commented on March 15, 2013 at 5:45 pm

    When I tried opening it with winRAR, it said that there is nothing inside the .zip file

  • berlin commented on March 17, 2013 at 11:34 pm

    Hi i can’t find the ModLoader.addOverride(“/terrain.png”, …… in rhe new release!

    and where can i find the api?

    thanks

  • BlupHox commented on March 21, 2013 at 1:46 pm

    Im first person what did say it worksIT REALLY WORKS

  • Miner commented on March 21, 2013 at 6:14 pm

    Yes good for you. NOT WORKING FOR 1.5.1 ONLY FOR 1.5

  • Kuhboose commented on March 21, 2013 at 6:19 pm

    The modloader isnt working with my 1.5.1, just leaving a black screen.

  • enderdragon71 commented on March 21, 2013 at 8:33 pm

    i inspected the file with winRAR its one of the files that is corrupted but the rest is fine

  • thevillage commented on March 23, 2013 at 9:45 pm

    The mod causes minecraft.exe to crash o me.

  • thevillage commented on March 23, 2013 at 9:45 pm

    And it was 1.5.1

  • maosha commented on March 24, 2013 at 1:14 pm

  • j commented on March 31, 2013 at 3:55 am

    it didnt work for me i am running 1.5.1 i have optifine and too many items and that is it please help

  • Santicol commented on April 6, 2013 at 7:49 pm

    Black screen. D: Now I gotta delete the files of the mod right? Or is my minecraft completely screwed now?

  • You Must Delete META-INF SO The Screen Dont Black Screen GO Watch On Youtube It Dont Happen To Me I Download Toomanyitems and Explosive+ mod and i didnt black screen no more it didnt work message

  • Nicole Vlqz commented on April 10, 2013 at 9:00 pm

    My minecraft stays in a black screen

  • IT WONT LOOOAAADDD

  • nick commented on April 14, 2013 at 10:19 pm

    whats rong with it? wen I try to open minecraft it crashes like it gets the the mojand c=symol but then it crashes? ny help?

  • AEPhoenix commented on April 15, 2013 at 12:55 pm

    Doesn’t work with winRAR

  • Bauto21 commented on April 18, 2013 at 10:33 pm

    no black screen for me =)

  • Nyan_Jesus commented on May 3, 2013 at 12:34 am

    Black Screen and this is not my first time downloading a mod its the 30th time Also It made me crash like about 5 times -.-

  • SkythegrandkidRS commented on May 3, 2013 at 12:56 am

    I hate these new updates coming out, all my mods aren’t even out yet for 1.5.0

  • Minecraft has crashed!
    ———————-

    Minecraft has stopped running because it encountered a problem; Exception occured in ModLoader

    A full error report has been saved to C:\Users\Olek\AppData\Roaming\.minecraft\crash-reports\crash-2013-05-05_13.35.16-client.txt – Please include a copy of that file (Not this screen!) if you report this crash to anyone; without it, they will not be able to help fix the crash :(

    — BEGIN ERROR REPORT 556a27a2 ——–
    Full report at:
    C:\Users\Olek\AppData\Roaming\.minecraft\crash-reports\crash-2013-05-05_13.35.16-client.txt
    Please show that file to Mojang, NOT just this screen!

    Generated 05.05.13 13:35

    – System Details –
    Details:
    Minecraft Version: 1.5.2
    Operating System: Windows 7 (x86) version 6.1
    Java Version: 1.7.0_15, Oracle Corporation
    Java VM Version: Java HotSpot(TM) Client VM (mixed mode), Oracle Corporation
    Memory: 448567256 bytes (427 MB) / 518979584 bytes (494 MB) up to 1037959168 bytes (989 MB)
    JVM Flags: 2 total; -Xms512m -Xmx1024m
    AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
    Suspicious classes: ModLoader, EntityRendererProxy, BaseMod, …]
    IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
    ModLoader: Mods loaded: 1
    ModLoader 1.5.2

    java.lang.VerifyError: (class: mod_MineColony, method: addRenderer signature: (Ljava/util/Map;)V) Incompatible argument to function
    at java.lang.Class.getDeclaredFields0(Native Method)
    at java.lang.Class.privateGetDeclaredFields(Unknown Source)
    at java.lang.Class.getDeclaredFields(Unknown Source)
    at ModLoader.setupProperties(ModLoader.java:1741)
    at ModLoader.addMod(ModLoader.java:342)
    at ModLoader.readFromModFolder(ModLoader.java:1202)
    at ModLoader.init(ModLoader.java:737)
    at ModLoader.addAllRenderers(ModLoader.java:205)
    at bgy.(RenderManager.java:97)
    at bgy.(RenderManager.java:14)
    at net.minecraft.client.Minecraft.a(SourceFile:261)
    at avv.a(SourceFile:56)
    at net.minecraft.client.Minecraft.run(SourceFile:507)
    at java.lang.Thread.run(Unknown Source)
    — END ERROR REPORT c610be16 ———-

  • Kaemixx commented on May 8, 2013 at 4:55 pm

    Minecraft crashed! I’m so angry.

  • steve commented on September 20, 2013 at 3:16 am

    Does it work in 1.6.2?

  • knightwing commented on October 11, 2013 at 3:37 pm

    when i use it in magic launcher with instant massive structures mod it says java.lang.ClassNotFoundException

  • connor commented on October 29, 2013 at 1:00 am

    Guys it works you just need 1.6.2

  • connor commented on October 29, 2013 at 1:02 am

    YES IT WORKS JUST NEED 1.6.2 and edo222000 none of the mods were updated for 1.6.4 it cam out a few weeks ago

  • Dylan commented on October 30, 2013 at 9:08 pm

    Will not let me drag and dropp modloader files into moddedminecraft.jar. PLEASE HEL

  • Julie785 commented on November 10, 2013 at 6:40 am

    I checked ModLoader for a virus and no threats :)

  • Tristan commented on December 20, 2013 at 4:00 am

    I can’t find the ‘moddedminecraft’ from the version list, even though I did all of the steps.What should I do to display the ‘moddedminecraft’ in the list?

  • teunknip99 commented on January 22, 2014 at 2:10 pm

    on magic launcher it says “not compatible”. how do i fix this?
    or will this be fixed?

  • creeper commented on April 2, 2014 at 6:37 pm

    it works thanks alot

  • peter commented on April 8, 2014 at 1:43 pm

    hey I have a windows so I cant do that what should I do also if u don’t respond in 1 hour or less I taking u to court

  • edo222000 commented on September 22, 2013 at 11:30 am

    and i am using 1.6.4